Su Linux puede ser pirateado simplemente abriendo un archivo en Vim o Neovim Editor

vulnerabilidad linux vim

Usuarios de Linux, ¡cuidado!

Si no ha actualizado recientemente su sistema operativo Linux, especialmente la utilidad de edición de texto de la línea de comandos, ni siquiera intente ver el contenido de un archivo usando Vim o Neovim.

investigador de seguridad armin razmjou descubrió recientemente una vulnerabilidad de ejecución de comandos de sistema operativo arbitrario de alta gravedad (CVE-2019-12735) en y No sé—Las dos aplicaciones de edición de texto de línea de comandos más populares y potentes que vienen preinstaladas con la mayoría de los sistemas operativos basados ​​en Linux.

En los sistemas Linux, el editor Vim permite a los usuarios crear, ver o editar cualquier archivo, incluido texto, scripts de programación y documentos.

Dado que Neovim es solo una versión bifurcada extendida de Vim, con una mejor experiencia de usuario, complementos y GUI, la vulnerabilidad de ejecución del código también reside en él.

Error de ejecución de código en Vim y Neovim

Razmjou descubrió una falla en la forma en que el editor de Vim maneja los «modelos», una función que está habilitada de forma predeterminada para buscar y aplicar automáticamente un conjunto de preferencias personalizadas mencionadas por el creador de un archivo cerca de las líneas de inicio y final del documento.

Linux-vim-vulnerabilidad

Aunque el editor solo permite un subconjunto de opciones en los modelos (por razones de seguridad) y usa la protección de espacio aislado si contiene una expresión insegura, Razmjou reveló que usar «: fuente!» comando (con una explosión [!] modificador) se puede utilizar para evitar el sandbox.

Por lo tanto, el simple hecho de abrir un archivo especialmente diseñado de aspecto inocente con Vim o Neovim podría permitir a los atacantes ejecutar comandos en secreto en su sistema Linux y tomar el control remoto sobre él.

El investigador también ha lanzado al público dos exploits de prueba de concepto, uno de los cuales demuestra un escenario de ataque de la vida real en el que un atacante remoto obtiene acceso a un shell inverso del sistema de la víctima tan pronto como abre un archivo en eso.

Los mantenedores de Vim (parche 8.1.1365) y Neovim (lanzado en v0.3.6) han lanzado actualizaciones para ambas utilidades para abordar el problema, que los usuarios deben instalar lo antes posible.

Además de esto, el investigador también ha recomendado a los usuarios:

  • deshabilitar la función de modelines,
  • deshabilite «modelineexpr» para no permitir expresiones en modelines,
  • use el «complemento de modelos seguros», una alternativa segura a los modelos de Vim.

Continua leyendo

Deja una respuesta

Tu dirección de correo electrónico no será publicada.

Newsletter Signup

Suscríbete a nuestra lista si te interesa recibir turcos exclusivos sobre hacking y seguridad informática